Help with build script SDK patches

Hi I’m trying to rebuild my server image.

U-Boot based on SDK10. Where do I get this from?

“Extract the git-u-boot–.tar.bz2 under the destination folder git-u-boot-- and copy the patches”

What should I be doing regarding the SDK U-Boot patches before I run the runme script?

Also some other things:
I’ve had a few compile issues with out of date packages. I.e m4, fakeroot (another poster mentions fakeroot). I’ve managed to work around these by updating the packages.

cd path/to/buildroot
git remote add upstream GitHub - buildroot/buildroot: Buildroot, making embedded Linux easy. Note that this is not the official repository, but only a mirror. The official Git repository is at Do not open issues or file pull requests here.
git fetch upstream master

then (from within the “buildroot” repo or subrepo)
rm -r package/m4
git checkout upstream/master – package/m4
git add -A
git status
git commit -m “Update m4 library”

I currently seem to have a problem with the script compiling U-Boot (hence my question above about patches). But my current error seems related to a bug when using gcc11, i’m might revert to gcc9.

[edit:] downgrading to gcc-9 didn’t work, gave more errors.
original issue - usr/bin/ld: scripts/dtc/ multiple definition of ‘yylloc’; scripts/dtc/dtc-lexer.lex.o:(.bss+0x0): first defined here

this fixed it:
edit the file ./linux-rtk/scripts/dtc/dtc-lexer-lex.c
Find the line ‘YYLTYPE yylloc’ and change it to ‘extern YYLTYPE yylloc
[end edit]

Many thanks