CuBox-M Quad not powering USB devices

I’ve got 3 CuBox-M Quad modules for evaluation, The first problem I’ve noticed is that attaching a USB device to the USB host ports on the CuBox will not power the USB devices. It is unclear to me if this is a problem with the batch of units I’ve received, or if I’m doing something wrong.

What I’ve tried:
I downloaded the pre-built image from Here

and flashed it, then booted up, I can see the OpenEmbedded GUI served over HDMI, but connecting a mouse/keyboard to the USB host ports doesn’t work, the mouse isn’t even powered.

Am I missing something fundamental or do I have faulty boards?

I believe those images need to be rebuilt with some additional patches. You can test with the Debian images that are available here I will get the Yocto images updated ASAP and update this thread when the CI has built them.

Thanks for your response jnettlet, but the link you provided is broken

Isn’t the modern internet fun. Here is the generic link, SolidRun Images

1 Like

That link works thanks!

So I’ve zeroed my sdcard and dd transferred Debian bullseye.

I’m assuming the image doesn’t come with a UI since there’s no HDMI signal, which is fine, but I still can’t get the mouse to power up.

I also can’t check if it is actually detected as a USB HID device since there’s a password on the ssh root login which I do not know (where can I find this password?), and the serial console doesn’t work, but I’m assuming it has the same issue since the mouse isn’t powered

To be more specific, I have this product: IMX8m plus CuBox M, and the power adapter that is suggested on the same purchase site.

Managed to get a serial console on one of the boards (previous board did not work), so I tried checking for a storage device from u-boot:

after attaching a USB thumb driver, and interrupting the boot process, I see:

Fastboot: Normal
Normal Boot
Hit any key to stop autoboot:  0
u-boot=> usb start
starting USB...
Bus usb@38100000: Register 2000140 NbrPorts 2
Starting the controller
Bus usb@38200000: Register 2000140 NbrPorts 2
Starting the controller
scanning bus usb@38100000 for devices... 1 USB Device(s) found
scanning bus usb@38200000 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found

it cannot find the storage device, so I believe it’s a power issue, but maybe this is expected? Am I supposed to do something to the CuBox to get the USB host to function?

I will post an image for you to test. Sorry about the confusion I thought my patches had been merged into that image already.

Thank you jnettlet, but what would be helpful is knowing how to make the changes in your yocto layer (or extending it with a bb to add the changes in our own layer), which would make more sense for our workflow.

in an email, someone from solidrun suggested the following to test:

echo 7 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio7/direction
echo 1 > /sys/class/gpio/gpio7/value

This works, so I"m trying to figure out where to make this change to be the default behaviour of the platform