Problem booting with UEFI, can't see USB or M.2 devices as boot options


I’ve got a HoneyComb LX2 machine, which until very recently has been working OK.

I rebooted it though, and when it restarted, and there wasn’t an option in the boot menu corresponding to the M.2 SSD. More worrying than this, I’ve tried various USB sticks with different images on them for distro installers (Ubuntu, Debian, …) and nothing appears for them either.

I’ve tried re-imaging the SD card (with images for 2400 and 2600 RAM speeds), tried two different sets of RAM, and various USB sticks with various images on them as I said before, so I’m running out of ideas. It’s hard to remember when I got it to boot from USB previously, but I don’t remember it being this difficult.

Any ideas?



NOTICE:  BL2: v2.4(release):v2.0-4471-g865d93d7e
NOTICE:  BL2: Built : 15:46:38, Aug  9 2021
NOTICE:  DDR4 UDIMM with 2-rank 64-bit bus (x8)

NOTICE:  64 GB DDR4, 64-bit, CL=16, ECC off, 256B, CS0+CS1
NOTICE:  BL2: Booting BL31
NOTICE:  BL31: v2.4(release):v2.0-4471-g865d93d7e
NOTICE:  BL31: Built : 15:46:42, Aug  9 2021
NOTICE:  Welcome to lx2160acex7 BL31 Phase

UEFI firmware built at 15:45:33 on Aug  9 2021. version:
SOC: LX2160ACE Rev2.0 (0x87360020)
UEFI firmware (version 202105 built at 15:45:36 on Aug  9 2021)

When you plug in your USB device, if it has a power light indicator, does it power up? If so then most likely something has removed the devices from the boot manager. You should go and check the boot configuration menu and reset it using F10.

Thanks for the suggestion Jon.

I’ve gone to the Boot Maintenance Manager screen, and pressed F9 to reset, which seems to do something. But then I see this message when I try to exit and save the changes:

Trying to delete a boot option seems to have sort of worked, but I got a similar error.

Do you know what could be causing the “Submit Fail” for the form?

Some more debugging information. I’ve got a second board to test with now, and when I put the same M.2, USB device and SD card in that second board, everything works as expected. I see both devices in the list of boot options, where on the first board, they’re both missing.

Any ideas what could be wrong with the first board that’s causing these boot devices to be missing?

Most likely something has filled the UEFI Variable storage on the spi-nor flash. Unfortunately edk2 is very bad at handling this circumstance. You can boot from a u-boot image and erase the full spi-nor flash and it should fix the problem. Let me know if you need the commands.

Thanks. I’ve managed to boot from a u-boot image, and I’m guessing it’s the sf erase command that I need to use, but my attempts at figuring out the arguments to pass don’t seem to have worked.

What are the commands you’d recommend?

sf probe
sf erase 0 0x4000000

Amazing, thanks so much for your help Jon.

That seems to have done the trick, I’ve successfully booted from USB and M.2 devices multiple times now :smiley: