Boot Image Issue from Quick Start Guide

I am trying to just run the Debian image as described in the quick start guide for the Hummingboard 2 Edge found here. I am running on a brand new out of the box device. Hardware version is 1.4.

I have downloaded the file sr-imx6-debian-bullseye-20220712-cli-sdhc.img.xz and flashed to a micro SD card using etcher. I have also verified that on header J5005, there are jumpers on pins 3+4 and 5+6. I then insert the SD card and supply power to the board.

It seems like u-boot is found and runs, but then it tries to load the kernel from EMMC which has nothing on it. Here is a picture of the what I see over the UART terminal.

Is this a known issue, or maybe there are some steps I missed? There is a custom image I have tried from a co-worker and it boots and loads the custom kernel, but of course it is meant to work with other hardware and there are lots of failures. It does show however that it seems the board itself is ok, and there is something going on with the solid run images. I have tried a couple different images with the same result from the solid run images.