Problems with their Solutions

Together with Jon Nettleton I found and provided the solutions to 15 Problems. Today I will share all 15 Problems with their fixes in both English and German.

English:

  1. Computer won’t boot: be sure that you have the right image: (SolidRun Images) pick the image for your RAM speed.

  2. Old graphicscard wasn’t compatible: take a newer graphicscard ( for example the AMD Radeon RX580)

  3. The LED of the powerswitch won’t light up: be sure that pin PLED+ is put on port 2 and that pin PLED- is put on port 5. See the bottom of this picture:
    https://marcin.juszkiewicz.com.pl/files/2021/02/honeycomb-layout.webp

  4. Computer turns off after a while:
    set “thermal.crt=-1” in /etc/default/grub in the GUB_CMDLINE_LINUX_DEFAULT like this: GRUB_CMDLINE_LINUX_DEFAULT=“loglevel=4 thermal.crt=-1”

  5. Graphic-glitches (in case of GPUs from AMD): like described in the 4th problem: “amdgpu.pcie_gen_cap=0x4” has to be set with a space between options in the GRUB_CMDLINE_LINUX_DEFAULT.

  6. Keyboard gets unmounted at boot of distro: be sure that the keyboard is plugged into the lower USB-port and that the mouse is plugged into the upper USB-port.

  7. Audio over USB Headset: execute:
    “touch /etc/modprobe.d/alsa.conf” "echo “options snd slots=snd-usb-audio,snd-hda-codec-hdmi” >> /etc/modprobe.d/alsa.conf

  8. I/O error of /dev/sda (bad cable): be sure to use a recent SATA cable. (mine was from 2005).

  9. Void Linux boots to the emergency shell: be sure that you have the newest tarball version of Void Linux (in my case 20210316 (Index of /live/20210316/))

  10. Void Linux has no wifi: execute:
    “wpa_passphrase SSID password /etc/wpa_supplicant/wpa_supplicant.conf” “wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf” “ln -s /etc/sv/wpa_supplicant /var/service/” “ln -s /etc/sv/dhcpcd /var/service/”

  11. Void Linux, operation not permitted at xbps-install:
    execute: “export SSL_NO_VERIFY_PEER=1”

  12. Void Linux, setting the time and sync it to hardwareclock:
    execute: “xbps-install ntp openntpd” “ntpdate pool.ntp.org” “openntpd -s” “hwclock -wl” “echo “openntpd-s; hwclock -wl” >> ~/.xinitrc”

  13. no ethernet under Void Linux: a USB-wifi or a RJ-45 adapter must be used.

  14. PSU did not have the right plug for the graphicscard : use a recent PSU (mine was from 2005).

  15. Vsync on Void: execute: “xbps-install picom” “echo “picom --backend-glx --vsync” >> ~/.xinitrc”

German:

  1. Computer wollte nicht booten: sicherstellen, das man das richtige Image hat (SolidRun Images) das Image für die Geschwindigkeit des Rams muss ausgewählt werden.

  2. Alte Grafikkarte war nicht kompatibel: eine neuere Grafikkarte nehmen (in meinem Fall z.B. die AMD Radeon RX580)

  3. Die Powerswitch LED leuchtet nicht: sicherstellen, dass der Pin PLED+ auf 2 gesteckt ist und der Pin PLED- auf 5 gesteckt ist. Siehe unten auf dieser Abbildung:
    https://marcin.juszkiewicz.com.pl/files/2021/02/honeycomb-layout.webp

  4. Computer geht nach einer Weile aus:
    “thermal.crt=-1” in /etc/default/grub in der GUB_CMDLINE_LINUX_DEFAULT setzen also: GRUB_CMDLINE_LINUX_DEFAULT=“loglevel=4 thermal.crt=-1”

  5. Grafik-glitches (bei einer GPU von AMD): wie beim oberen Problem:
    “amdgpu.pcie_gen_cap=0x4” muss mit einem Space zwischen die anderen Optionen in der GRUB_CMDLINE_LINUX_DEFAULT gesetzt werden.

  6. Tastatur wird beim booten ausgeworfen: sicherstellen, dass die Tastatur an den unteren USB-port und die Maus an den oberen USB-port angeschlossen ist.

  7. Audio über USB Headset: auszuführende Kommandos:
    “touch /etc/modprobe.d/alsa.conf” "echo “options snd slots=snd-usb-audio,snd-hda-codec-hdmi” >> /etc/modprobe.d/alsa.conf

  8. I/O error bei /dev/sda (bad cable): darauf achten, dass ein aktuelles, Kabel genutzt wird. (Ich hatte ein Kabel von 2005 genutzt).

  9. Void Linux bootet in die emergency Shell: sicherstellen, dass der neueste .tar.xz Version von Void Linux (in meinem Fall 20210316 (Index of /live/20210316/))

  10. Void Linux hat kein Wlan: auszuführende Kommandos:
    “wpa_passphrase SSID Passwort /etc/wpa_supplicant/wpa_supplicant.conf” “wpa_szpplicant -B -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf” “ln -s /etc/sv/wpa_supplicant /var/service/” “ln -s /etc/sv/dhcpcd /var/service/”

  11. Void Linux, operation not permitted bei xbps-install:
    auszuführendes Kommando: “export SSL_NO_VERIFY_PEER=1”

  12. Void Linux Zeit setzen und speichern: auszuführende Kommandos:
    “xbps-install ntp openntpd” “ntpdate pool.ntp.org” “openntpd -s” “hwclock -wl” “echo “openntpd-s; hwclock -wl” >> ~/.xinitrc”

  13. Kein Ethernet: Ein USb-wifi oder ein RJ-45 Adapter muss genutzt werden.

  14. Netzteil hatte keinen richtigen Stecker für Grafikkarte: anderes, neueres Netzteil nutzen (Meins war von 2005)

  15. Vsync auf Void: auszuführende Kommandos:
    “xbps-install picom” “echo “picom --backend-glx --vsync” >> ~/.xinitrc”

“Modern problems need modern solutions” “moderne Probleme brauchen moderne Lösungen”

Thanks for the write up. I just posted new edk2 images that should fix the need for number 4 on your list. I have also posted new kernel repositories to go with this firmware, linux-5.10.y-cex7-latest, and linux-5.12.y-cex7.

1 Like

Awesome, I have also installed both funtoo and gentoo as of today with the 5.14-rc2 linux kernel. I enabled the option “arm-smmu.disable_bypass=0” and got Internet over ethernet via dhcpcd I did a cli speedtest and I get the full Internet speed :+1:.

Yes, 5.14-rc2 finally landed the patches we needed for basic networking support with the smmu bypassed. Hopefully the additional patches will land soon so we will have full support out of the box.

1 Like

Is it possible to take out the SD-card where the UEFI is flashed onto and then flash new firmware onto it while the distribution is running? I found out that the Image must be wirtten with dd.

I have now integrated the Linux 5.14-rc3 kernel into Voidlinux. Does the linux-stable kernel from SolidRun have AMDGPU hardware acceleration and sound via ALSA? My GPU fans are not spinning and i get little FPS in games.

I also tried out the SolidRun Kernel with Voidlinux, which stops in the bootprocess, after EFI outputs are displayed in the middle of the screen.

The SD-Card is only used during the boot process and can be removed during use, I do it all the time for testing. You should note that sometimes when doing this the card detect is missed and you have to take the card out and press it back in again and hit the reset button, or fully power off the board for it to be able to access the SDHC card.

The SolidRun kernel only has few patches specifically for features needed with ACPI. These do not include anything regarding PCIe or the AMDGPU. The default kernel config does not include amdgpu by default which is most likely what you are seeing. I would recommend using your Voidlinux .config file with our kernel branch.

1 Like

That’s a really good idea. what is also odd, is that it is given a weird name when i generate an initramfs.img for it:
“5.2.0-rc6-g249155c20-dirty”

To build the Kernel I also put the extern keyword in front of YYLTYPE yylloc; in /scripts/dtc/dtc-lexer.l in line 41, because of the “multiple definiton of yylloc” build error.

Update: glxinfo says “direct rendering: yes” which means that HW acceleration is active but it also says: “accelerated: no”. But i think I know now: My GPU is just not getting initialized by the Linux 5.14-rc3 kernel. “sensors” command on 5.13.5 shows temperature of both the GPU and CPU while on 5.14 only the CPU temperatures are shown.

Alsamixer won’t start on 5.14 aswell.

I Have successfully integrated the SolidRun’S linux-stable Kernel into VoidLinux I first forgot to recompile it after copying the .config, which would result in it not booting. The “Unknown SOC” error is gone like expected, but I have no Internet over ethernet on SolidRun’s kernel, which I do have on Linux 5.14-rc3.

I need to somehow tell the kernel where the firmware lies (for proper graphics acceleration and sound). Self-compiled kernels do not find the package “linux-firmware-amd” even though i have it installed.

Please provide your dmesg output from your kernel so I can assist with the networking. The firmware loading question is better targeted to a Void linux support channel, since they will be able to assist you better.

1 Like

Right, Here you go:
This is the output of the 5.14-rc3 Kernel i will send a picture of the dmesg output of SolidRun’s Kernel.

[ 0.822202] ALSA device list:
[ 0.822207] No soundcards found.
[ 0.824683] hub 3-1:1.0: USB hub found
[ 0.824730] hub 3-1:1.0: 4 ports detected
[ 0.864949] hid-generic 0003:0C45:8513.0001: input: USB HID v1.11 Keyboard [SONiX USB DEVICE] on usb-xhci-hcd.1.auto-1/input0
[ 0.868970] input: SONiX USB DEVICE Keyboard as /devices/platform/808622B7:00/xhci-hcd.1.auto/usb1/1-1/1-1:1.1/0003:0C45:8513.0002/input/input2
[ 0.908809] usb 4-1: new SuperSpeed USB device number 2 using xhci-hcd
[ 0.928898] input: SONiX USB DEVICE as /devices/platform/808622B7:00/xhci-hcd.1.auto/usb1/1-1/1-1:1.1/0003:0C45:8513.0002/input/input3
[ 0.928970] hid-generic 0003:0C45:8513.0002: input: USB HID v1.11 Keyboard [SONiX USB DEVICE] on usb-xhci-hcd.1.auto-1/input1
[ 0.952663] hub 4-1:1.0: USB hub found
[ 0.952706] hub 4-1:1.0: 4 ports detected
[ 0.993379] sdc: sdc1
[ 0.994029] sd 3:0:0:0: [sdc] Attached SCSI disk
[ 0.995393] Freeing unused kernel memory: 6080K
[ 0.995477] Run /init as init process
[ 0.995479] with arguments:
[ 0.995481] /init
[ 0.995482] with environment:
[ 0.995484] HOME=/
[ 0.995486] TERM=linux
[ 0.995487] BOOT_IMAGE=/boot/vmlinux-5.14.0-rc3
[ 1.056904] random: fast init done
[ 1.140809] raid6: neonx8 gen() 5514 MB/s
[ 1.176791] usb 3-1.2: new full-speed USB device number 3 using xhci-hcd
[ 1.208778] raid6: neonx8 xor() 4158 MB/s
[ 1.276777] raid6: neonx4 gen() 5756 MB/s
[ 1.344777] raid6: neonx4 xor() 4326 MB/s
[ 1.369633] input: SINOWEALTH Game Mouse as /devices/platform/808622B7:01/xhci-hcd.2.auto/usb3/3-1/3-1.2/3-1.2:1.0/0003:258A:1007.0003/input/input4
[ 1.369693] hid-generic 0003:258A:1007.0003: input: USB HID v1.11 Mouse [SINOWEALTH Game Mouse] on usb-xhci-hcd.2.auto-1.2/input0
[ 1.372294] input: SINOWEALTH Game Mouse Keyboard as /devices/platform/808622B7:01/xhci-hcd.2.auto/usb3/3-1/3-1.2/3-1.2:1.1/0003:258A:1007.0004/input/input5
[ 1.412776] raid6: neonx2 gen() 5082 MB/s
[ 1.428856] hid-generic 0003:258A:1007.0004: input: USB HID v1.11 Keyboard [SINOWEALTH Game Mouse] on usb-xhci-hcd.2.auto-1.2/input1
[ 1.480776] raid6: neonx2 xor() 3958 MB/s
[ 1.508798] usb 3-1.3: new high-speed USB device number 4 using xhci-hcd
[ 1.548779] raid6: neonx1 gen() 3936 MB/s
[ 1.616764] raid6: neonx1 xor() 3142 MB/s
[ 1.656589] hub 3-1.3:1.0: USB hub found
[ 1.656646] hub 3-1.3:1.0: 4 ports detected
[ 1.684771] raid6: int64x8 gen() 3113 MB/s
[ 1.752794] raid6: int64x8 xor() 1886 MB/s
[ 1.820792] raid6: int64x4 gen() 3352 MB/s
[ 1.888793] raid6: int64x4 xor() 1908 MB/s
[ 1.956788] raid6: int64x2 gen() 3154 MB/s
[ 2.008788] usb 3-1.3.2: new high-speed USB device number 5 using xhci-hcd
[ 2.024788] raid6: int64x2 xor() 1740 MB/s
[ 2.092767] raid6: int64x1 gen() 2440 MB/s
[ 2.160768] raid6: int64x1 xor() 1278 MB/s
[ 2.160771] raid6: using algorithm neonx4 gen() 5756 MB/s
[ 2.160774] raid6: … xor() 4326 MB/s, rmw enabled
[ 2.160776] raid6: using neon recovery algorithm
[ 2.162099] xor: measuring software checksum speed
[ 2.163279] 8regs : 8377 MB/sec
[ 2.164300] 32regs : 9659 MB/sec
[ 2.165555] arm64_neon : 8113 MB/sec
[ 2.165560] xor: using function: 32regs (9659 MB/sec)
[ 2.175356] Btrfs loaded, crc32c=crc32c-generic, zoned=no
[ 2.288033] systemd-udevd[344]: starting version 3.2.10
[ 2.288418] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[ 2.288452] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[ 2.288487] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[ 2.289792] udevd[345]: starting eudev-3.2.10
[ 2.389537] ftm-alarm NXP0014:00: registered as rtc1
[ 2.393417] nvme 0002:01:00.0: Adding to iommu group 7
[ 2.393747] nvme nvme0: pci function 0002:01:00.0
[ 2.517144] nvme nvme0: missing or invalid SUBNQN field.
[ 2.544260] nvme nvme0: allocated 128 MiB host memory buffer.
[ 2.685184] nvme nvme0: 8/0/0 default/read/poll queues
[ 2.693680] nvme0n1: p1 p2
[ 2.965667] EXT4-fs (nvme0n1p2): mounted filesystem with ordered data mode. Opts: (null). Quota mode: none.
[ 3.018347] dracut: Checking ext4: /dev/disk/by-uuid/606e8bf3-8e78-48b6-a215-e6ec3785e546
[ 3.018654] dracut: issuing e2fsck -a /dev/disk/by-uuid/606e8bf3-8e78-48b6-a215-e6ec3785e546
[ 3.046248] dracut: /dev/disk/by-uuid/606e8bf3-8e78-48b6-a215-e6ec3785e546: clean, 430456/61038592 files, 12900439/244124849 blocks
[ 3.049041] dracut: Mounting /dev/disk/by-uuid/606e8bf3-8e78-48b6-a215-e6ec3785e546 with -o defaults,ro
[ 3.072361] EXT4-fs (nvme0n1p2): mounted filesystem with ordered data mode. Opts: (null). Quota mode: none.
[ 3.096668] dracut: Mounted root filesystem /dev/nvme0n1p2
[ 3.165983] dracut: Switching root
[ 3.292790] fuse: init (API version 7.34)
[ 3.301835] device-mapper: ioctl: 4.45.0-ioctl (2021-03-22) initialised: dm-devel@redhat.com
[ 3.320312] udevd[553]: starting version 3.2.10
[ 3.321315] urandom_read: 3 callbacks suppressed
[ 3.321320] random: udevd: uninitialized urandom read (16 bytes read)
[ 3.321484] random: udevd: uninitialized urandom read (16 bytes read)
[ 3.321505] random: udevd: uninitialized urandom read (16 bytes read)
[ 3.333200] udevd[554]: starting eudev-3.2.10
[ 4.379783] EXT4-fs (nvme0n1p2): re-mounted. Opts: (null). Quota mode: none.
[ 4.576578] random: crng init done
[ 4.576583] random: 1 urandom warning(s) missed due to ratelimiting
[ 4.601603] EXT4-fs (nvme0n1p2): re-mounted. Opts: (null). Quota mode: none.
[ 4.686184] NET: Registered PF_INET6 protocol family
[ 4.686692] Segment Routing with IPv6
[ 4.694657] udevd[668]: starting version 3.2.10
[ 4.698102] udevd[668]: starting eudev-3.2.10

I have also put the config of the linux5.13 package into 5.14-rc3 and it would compile all the drivers which i suspect would give me proper graphics and sound (compilation took 40 minutes, defconfig takes 12).

I need the beginning of dmesg as well, so I can see why the ethernet driver is not loading. Thanks

1 Like

It says that i can only mention 10 users in a post.
I cannot open a topic aswell, because of the above.

It is probably easier to debug this if you join our discord server. Developer-Ecosystem

1 Like

Good, is there also a matrix.org integration for this room, because discord is privacy-unfriendly, but i will join anyway if there is no matrix.org integration.

We do not use matrix.org. Our discord is a public community chat area so we don’t see any privacy issues.

Oh, no that’s not the case. The Discord App spies on its users due to it being proprietary.

I just use the web client.

1 Like

I can add to 3. that the PLED connector is a bit dangerous for most LEDs.

I connected the power LED from my Chenbro SR301 Plus case correctly on the board (Clearfox CX Rev 1.3), but the LED did not light up. However, the HDD LED worked without any problems.
After that I connected the HDD LED to the PLED connector, but it didn’t work there either.
When I connected the HDD-LED back to the HDD-LED connector again, the HDD-LED didn’t work anymore. So both LEDs were destroyed by the PLED connector.

I bought two new LEDs and added a 100R resistor to the PowerLED. Now everything works fine.

I took a look at the schematic and it looks like there is 5V at the PLED connector and no pre-resistor is installed. I don’t know if this is how it is supposed to be, but I think the connector is not suitable for most computer cases.

We have noted in the errata that the PLED ground is not connected and for a functional PLED it requires a different ground connection. The circumstances you described from a motherboard point of view is not electrically possible since the ground pin on the PLED is not connected to anything. That means you motherboard has shipped a non ATX compatible front panel LED configuration. Based on Intel’s ATX spec the PLED is +5V with no resistor required. Since this configuration is tested with multiple other case vendors without issue, I recommend you file a bug with Chenbro.