LX2 honeycomb boot sequence stucked

Hi, tried over the week to have the board booting without any success.
It won’t go further than “NOTICE: 64 GB DDR4, 64-bit, CL=19, ECC on, 256B, CS0+CS1”

NOTICE:  BL2: v2.4(release):v2.0-4471-g865d93d7e
NOTICE:  BL2: Built : 15:47:28, Aug  9 2021
NOTICE:  DDR4 UDIMM with 2-rank 64-bit bus (x8)

NOTICE:  64 GB DDR4, 64-bit, CL=19, ECC on, 256B, CS0+CS1

Could it be a RAM issue? According to the notice, my RAM is 18ASF4G72HZ-2G6B1 and after a research I found out that it is rated at 2666Mts. I’m wondering since the RAM I purchased is wrongly labeled as 18ASF4G72HZ-3G2B1 3200Mts … so who knows…!

This is Crucial ECC memory? If it is rated at 2666Mts then you should just need to use an image configured for 2600 memory speeds.

Can you test with just a single DIMM installed?

Thanks for pointing me in the good direction! I wonder why I didn’t thought to it myself…!
Following your advice I did installed the DIMM#1 in slot 1&2, and the DIMM#2 in slot 1&2.

I found out that one of my 2 DIMM is faulty (Micron MTA18ASF4G72HZ) and was silently failing. The error code are pretty clear when installing only 1 memory strip.

The good DIMM work as expected in either slot 1&2.

Problem solved, thank you and have a good day!

1 Like